Epson printer WF 3620



  • Will the Epson printer WF 3620 work with Ubuntu 14.04 LTS software?



  • Checked on the Epson Supplier,
    support system does not have Ubuntu 14.04 LTS.

    Operating Systems:
    Windows® 8.x (32-bit, 64-bit)
    Windows 7 (32-bit, 64-bit)
    Windows Vista® (32-bit, 64-bit)
    Windows XP® SP3 (32-bit)
    Windows XP Professional x64 Edition
    Mac OS®X 10.5.8 — 10.9.x6
    Server Systems:
    Windows Server® 2012 R27
    Windows Server 20127
    Windows Server 2008 R27
    Windows Server 20087
    Windows Server 2003 R27
    Windows Server 20037


Log in to reply
 

3
Online

2.5k
Users

3.5k
Topics

7.0k
Posts

Looks like your connection to Shopper+ Forum Canada was lost, please wait while we try to reconnect.